Windows 10 – Cannot open module file 'toolbox.mod'

Forums Installation Problems Windows Users Windows 10 – Cannot open module file 'toolbox.mod'

This topic contains 2 replies, has 2 voices, and was last updated by Fabian Kindermann November 13, 2020 at 9:03 am.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #1887

    Dinith Marasinghe
    User

    Hi all,

    I have installed the compiler on two different windows 10 computers and they worked perfectly fine. However, my work PC (which is also windows 10) gives the following error when I try to compile.

    “Fatal Error: Cannot open module file ‘toolbox.mod’ for reading at (1): No such file or directory”

    I have tried re-installing the compiler and installing the toolbox manually, but still I am getting the error. Furthermore, I see the ‘toolbox.mod’, ‘toolbox.o’ etc in C/cygwin/include. I’m unsure as to what’s causing the error.

    Any help is greatly appreciated. Thanks!

    Kind regards,
    Dinith

    #1888

    Dinith Marasinghe
    User

    Managed to fix it. I fixed it by changing the following in my Set Build Commands (Build > Set build commands)

    My default commands were:
    Compile: gfortran -Wall -c “%f”
    Build: gfortran -Wall -o “%e” “%f”.
    Execute: “%e”

    I changed them to:
    Compile: gfortran -O3 -Werror -Wno-unused -fimplicit-none -Wall -fcheck=bound,do -ffpe-trap=invalid,zero,overflow -I”C:\cygwin\include” -c “%f” -o “%e.o”

    Build: gfortran -O3 “C:\cygwin\include\toolbox.o” “%e.o” -o prog

    Execute command:”prog”

    I’m not sure as to why these commands weren’t available upon installation. In both my other computers, these were already present.

    The following post on this forum helped me quite a lot. I suggest having a read that too.

    Link to a library in geany?

    Best,
    Dinith

    #1889

    Fabian Kindermann
    Moderator

    Dear Dinith,

    great so see that you fixed the problem yourself. I am not sure why this happened. Usually, when geany is installed on your computer, we install a configuration file that geany looks to when using an .f90 program. This file contains the compiler statement and links to the toolbox. It might be that on your work PC you don’t have the rights to write a file to the geany configuration directory. This might cause the error you described.

    Best,
    Fabian

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.