Error running program 1.17, GNUplot

Forums Questions on specific programs Error running program 1.17, GNUplot

Tagged: 

This topic contains 2 replies, has 2 voices, and was last updated by Tian L March 17, 2019 at 6:59 pm.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #1609

    Tian L
    User

    Dear All,

    I’m using macOS Mojave 10.14.3. I’m having trouble running program 1.17. It showed:
    sh: gnuplot: command not found
    sh: gnuplot: command not found
    sh: gnuplot: command not found

    I tried the solution in this post: uninstall the whole program and do a clean reinstall. But it didn’t work.
    When I typed which gnuplot in the terminal, it didn’t show anything.

    I also tried the solution in this post: use brew install gnuplot --with-wxmac --with-cairo
    But it showed an error message “invalid option: –with-wxmac”.

    Can someone help me with problem? Thank you very much!

    #1621

    Fabian Kindermann
    Moderator

    Dear Tian,

    sorry for being a little late with my response, but we are currently working on a solution manual to the exercise section of the book.

    I just recently became aware of this problem trying to install gnuplot through homebrew on macOs Mojave. I’ve fixed this in the installation routine as well as the toolbox. If you download the new installation package, everything should work fine. The ideal procedure is to download the new package, first uninstall everything using the file uninstall_fortran.command. Once your current package is removed from the computer, run the new install_fortran.command and things should install automatically and correctly.

    If not, please let me know.

    #1628

    Tian L
    User

    Dear Professor Kindermann,

    Thank you very much! After I tried the new installation package, the codes worked well.

    Best,
    Tian

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.